Jump to content
  • Announcements

    • Admin_01

      Enhanced Reputation ("Like" and "Dislike") Functionality Here on CL   07/24/2017

      With the recent software upgrade, CL now has a slightly enhanced and more descriptive "reputation" functionality. The reputation is what CL members can click in the lower right corner of each posting (forums, blogs, calendar events, etc.) to indicate their "like' or "dislike" of that posting. This functionality, previously known as a member's "reputation", has been enhanced and is now known as a member's "reaction". Instead of having only two choices ("like" or "dislike", represented by a +1 or -1), there now are seven different "reactions" that a member can express, including the simple "Like" and "Dislike". As was the case previously with reputations, Administrators of this website cannot be given reputation/reaction, however Moderators can, just as all regular members can. Here in graphic form is the complete list of options in word and emoji form, along with the associated numeric value: The "Like" and the "Upvote" and the "Downvote" are essentially the same as the prior "like" and "dislike" reputation. Those are similar to what is available on some of the larger social media, such as Facebook. As in the past with reputation, the use of reactions is optional. Reputations (now "reactions") are not favored by everyone. Prior feedback indicates approximately 30% of CL's members prefer that "reputation" [and now "reactions"] be disabled. However, the majority of CL's members prefer having the ability to indicate their "like" or "dislike" of a posting. The new, enhanced functionality means simply that CL members have more granularity as to what they can indicate to the viewers. If anyone would like to see additional "reactions", please contact CL management, and include a short discussion of what you would like to see and perhaps an emoji to suggest that reaction. Two new reactions that have already been suggested are "I agree" and "I disagree", which might be expressed respectively with green check mark (or thumbs up) and red X-mark (or thumbs down) style emoji. The reactions functionality is currently configured to display who expressed that reaction. If there is sufficient feedback, we can hide the member's Display Name, and show only the cumulative reactions.           To provide general feedback or ask for help regarding Chiriqui.Life, please leave a posting in Problems, Feedback and Suggestions or email support@chiriqui.life or private message to @Admin_01.  
Deborah

Gas Water Heater Help Needed

Recommended Posts

Deborah    20

Need a recommendation for someone who can try to fix (or at least diagnose) an on demand gas water heater that won't ignite. Worked for a few minutes after replacing a loose regulator but not working again. Maybe has something to do with air getting into the line from the old regulator?

This is for the shop and we can't wash away chocolate with cold water!

Tried Luis Cotte, but no response.

Share this post


Link to post
Share on other sites
Penny    172

Always make the small investment in a new battery or batteries before you call the repairman.

You can tell a lot from how strong and loud the click, click, click of the ignition.

Also, take the regulator off the gas tank and firmly reset it on the tank.

 

Share this post


Link to post
Share on other sites

Yes, replace the battery.  Even if you hear the igniter clicking it is not necessarily getting enough juice.  Alkaline batteries are a must.  Learned all this from Luis Cotte after I nearly lost my mind trying to figure out the problem.  Other things that I have found to help:  Making sure the gas bottle has plenty of pressure (I push the valve pin down briefly with whatever small pointy object is handy...keeping my face clear of the gas )  and making sure there is no dirt in the regulator and that the pin makes good contact with the valve pin.  Hope this helps

Share this post


Link to post
Share on other sites
Deborah    20

thanks to those who suggested batteries, but getting new batteries was the first thing I did.  Regulator is also brand new, after battery replacement didn't work (and the regulator seemed loose no matter how I re-seated it after taking it off).  Someone (no expert) who looked at it today said that it may need cleaning in the line since it seems not enough gas is getting through to ignite. Who knows?  Having exhausted the tank, regulator and battery issues, I'm calling Millo tomorrow.  Funny thing is several people have told me they had the same problem and the solution for each turned out to be different.  I guess these heaters have several problems.

Edited by Deborah

Share this post


Link to post
Share on other sites
WryAwry    79

Is it attempting to fire? Ensure that the cold water inlet filter screen is not clogged. Should be on or adjacent to the cold connection. Typically will not require a tool to remove. Turn off water. Remove cap or plug. (Blue plastic?) (Lefty-loosey! Righty-tightly!) Do not damage o-ring seal. Clean screen (perhaps cylindrical in form) and replace carefully. Turn water back on, check for leaks, check operation. The unit depends upon a minimum flow to trigger ignition and sustain burner operation. I had one where varmints chewed the insulation from the ignitor wires, causing the spark to short out. A little electrical tape fixed that. You can also check for loose wire connectors inside the jacket, or there may be a safety switch that opened -- that's like turning off a light switch. Some of these safety switches may be re-settable with a tiny red push button directly between two wires with spade connectors. Is the thing breathing right? Flue unobstructed? Air inlets in jacket and/or bottom unobstructed?

How old is the unit? Over time, the water way through (actually wound-around) the heat exchanger can become restricted with lime or other mineral build-up. This requires cleaning with vinegar, which is a bit more complicated, but can be done by anyone with proper instruction.

There are certainly YouTube videos to help you learn more about these devices! Good luck, and please report back!

Dav

State of Colorado USA

Master Plumber License #179-842

  • Upvote 2

Share this post


Link to post
Share on other sites
JudyS    175
12 hours ago, Deborah said:

thanks to those who suggested batteries, but getting new batteries was the first thing I did.  Regulator is also brand new, after battery replacement didn't work (and the regulator seemed loose no matter how I re-seated it after taking it off).  Someone (no expert) who looked at it today said that it may need cleaning in the line since it seems not enough gas is getting through to ignite. Who knows?  Having exhausted the tank, regulator and battery issues, I'm calling Millo tomorrow.  Funny thing is several people have told me they had the same problem and the solution for each turned out to be different.  I guess these heaters have several problems.

I go through these trouble shooting steps when the gas heater doesn't work:

1.  Check to see that the propane tank isn't empty.

2.  Change the battery if the tank takes two or three tries to heat, then finally comes on.  This is a sign of a low battery.  If it doesn't come on at all -

3.  Blow compressed air on the gas outlets, especially the one the spark hits.  You have to take the cover off to do this.  The compressed air can clean out carbon bits that might be blocking the jets.  Use the canned air that you use to clean computer keyboards.

4.  If none of this works, try another tank of gas.  Sometimes (though rare) you will get a bad tank of gas.

5.  As a last resort, call a repairman.

Share this post


Link to post
Share on other sites
JohnF13    75

So, Deborah, nothing at all to do with your problem but I thought I might mention my water heater "failure".  Water heater running fine this morning, at lunchtime it was dead, the igniter was trying to work but no flame.  Have had this problem before and sure enough, when I took the cover off I saw that one of the contacts was disconnected.  Fixed it and fired the heater up, working fine.  But, says I, why did this happen?  Closer inspection revealed a bunch of leaves in the hot air output hole.  A bit further inspection revealed the culprit - a possum had crawled into the heater and was nesting on the top of the heater stack.  He is still there now, I have put out cat food to lure him out tonight.  Meanwhile, cold water only.  Oh well, joys and laughs of Panama.  Moral of the story, put a mesh grate over your heater exhaust vent!

  • Upvote 2

Share this post


Link to post
Share on other sites
Bonnie    393

I see possums at night every now and then, mostly at night. I saw a dead one in the road yesterday.

  • Upvote 1

Share this post


Link to post
Share on other sites
TwoSailors    86

Jeeze... that's a big sucker! The ones we have scene in California are all white. They used to torment our dogs and eat all our tomatoes!

Share this post


Link to post
Share on other sites
JohnF13    75

That's his big brother, Keith!  Bonnie, you are right about mean.  I poked a stick in there to try to get him out, he clamped down on it with his teeth and wouldn't let go.  That's when I heard a glass of wine calling me.  Manyana.......

Share this post


Link to post
Share on other sites
JohnF13    75

Twas a happy ending.  The squatter left overnight after eating the cat food I left out for him.  The exhaust vent now has a nice cage over it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×